#VU57942 Input validation error


Published: 2021-11-04

Vulnerability identifier: #VU57942

Vulnerability risk: Low

CVSSv3.1: 2.7 [CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:N/I:N/A:L/E:U/RL:O/RC:C]

CVE-ID: CVE-2021-39914

CWE-ID: CWE-20

Exploitation vector: Network

Exploit availability: No

Vulnerable software:
Gitlab Community Edition
Universal components / Libraries / Software for developers
GitLab Enterprise Edition
Universal components / Libraries / Software for developers

Vendor: GitLab, Inc

Description

The vulnerability allows a remote attacker to perform a denial of service (DoS) attack.

The vulnerability exists due to regular expression denial of service issue when cleaning namespace path. A remote authenticated attacker can pass specially crafted input to the application and perform a denial of service (DoS) attack.

Mitigation
Install updates from vendor's website.

Vulnerable software versions

Gitlab Community Edition: 8.13 - 14.4.0

GitLab Enterprise Edition: 8.13.0 - 14.4.0


CPE

External links
http://about.gitlab.com/releases/2021/10/28/security-release-gitlab-14-4-1-released/


Q & A

Can this vulnerability be exploited remotely?

Yes. This vulnerability can be exploited by a remote authenticated user via the Internet.

Is there known malware, which exploits this vulnerability?

No. We are not aware of malware exploiting this vulnerability.


Latest bulletins with this vulnerability