#VU60185 Insufficient verification of data authenticity


Published: 2022-01-31

Vulnerability identifier: #VU60185

Vulnerability risk: Low

CVSSv3.1: 4.1 [CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:L/A:L/E:U/RL:O/RC:C]

CVE-ID: CVE-2022-0336

CWE-ID: CWE-345

Exploitation vector: Network

Exploit availability: No

Vulnerable software:
Samba
Server applications / Directory software, identity management

Vendor: Samba

Description

The vulnerability allows a local user to impersonate arbitrary services.

The vulnerability exists due to Samba AD DC relies only on SPN (service principals name) to identify services on the network. An attacker with ability to modify SPNs can bypass implemented protection and cause a denial of service condition by adding an SPN that matches an existing service or impersonate services on the network.

Mitigation
Install updates from vendor's website.

Vulnerable software versions

Samba: 4.15.0 - 4.15.3, 4.14.0 - 4.14.11, 4.13.0 - 4.13.16, 4.12.0 - 4.12.15, 4.11.0 - 4.11.17, 4.10.0 - 4.10.18, 4.9.0 - 4.9.18, 4.8.0 - 4.8.12, 4.7.0 - 4.7.12, 4.6.0 - 4.6.16, 4.5.0 - 4.5.16, 4.4.0 - 4.4.16, 4.3.0 - 4.3.13, 4.2.0 - 4.2.14, 4.1.0 - 4.1.23, 4.0.0 - 4.0.26


CPE

External links
http://www.samba.org/samba/security/CVE-2022-0336.html


Q & A

Can this vulnerability be exploited remotely?

Yes. This vulnerability can be exploited by a remote authenticated privileged user via the Internet.

Is there known malware, which exploits this vulnerability?

No. We are not aware of malware exploiting this vulnerability.


Latest bulletins with this vulnerability