#VU60674 OS Command Injection


Published: 2022-02-17

Vulnerability identifier: #VU60674

Vulnerability risk: High

CVSSv3.1: 7.7 [CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H/E:U/RL:O/RC:C]

CVE-ID: CVE-2021-45444

CWE-ID: CWE-78

Exploitation vector: Network

Exploit availability: No

Vulnerable software:
zsh
Client/Desktop applications / Software for system administration

Vendor: SourceForge

Description

The vulnerability allows a remote attacker to execute arbitrary shell commands on the target system.

The vulnerability exists due to recursive PROMPT_SUBST expansion when processing malicious output. A remote attacker with ability to control the output can inject and execute arbitrary commands on the system with privileges on the current user.


Mitigation
Install updates from vendor's website.

Vulnerable software versions

zsh: 5.0.0 - 5.8


CPE

External links
http://zsh.sourceforge.io/releases.html
http://vuln.ryotak.me/advisories/63
http://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/2P3LPMGENEHKDWFO4MWMZSZL6G7Y4CV7/
http://www.debian.org/security/2022/dsa-5078


Q & A

Can this vulnerability be exploited remotely?

Yes. This vulnerability can be exploited by a remote non-authenticated attacker via the Internet.

Is there known malware, which exploits this vulnerability?

No. We are not aware of malware exploiting this vulnerability.


Latest bulletins with this vulnerability