#VU60858 Input validation error in pjsip


Published: 2022-02-24

Vulnerability identifier: #VU60858

Vulnerability risk: Medium

CVSSv3.1:

CVE-ID: CVE-2021-41141

CWE-ID: CWE-20

Exploitation vector: Network

Exploit availability: No

Vulnerable software:
pjsip
Universal components / Libraries / Libraries used by multiple products

Vendor: pjsip

Description

The vulnerability allows a remote attacker to perform a denial of service (DoS) attack.

The vulnerability exists due to the missing of unreleased locks in failure cases. A remote attacker can pass specially crafted input to the application and perform a denial of service (DoS) attack.

Mitigation
Install updates from vendor's website.

Vulnerable software versions

pjsip: 0.5.0.1 - 2.11.1


CPE

External links
http://github.com/pjsip/pjproject/security/advisories/GHSA-8fmx-hqw7-6gmc
http://github.com/pjsip/pjproject/commit/1aa2c0e0fb60a1b0bf793e0d834073ffe50fb196


Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?


Latest bulletins with this vulnerability