#VU60972 Security restrictions bypass


Published: 2022-03-30

Vulnerability identifier: #VU60972

Vulnerability risk: Medium

CVSSv3.1:

CVE-ID: CVE-2022-23648

CWE-ID: CWE-264

Exploitation vector: Network

Exploit availability: Yes

Vulnerable software:
containerd
Other software / Other software solutions

Vendor: containerd

Description

The vulnerability allows a remote attacker to gain access to sensitive information.

The vulnerability exists due to an error when handling specially crafted image configuration in containerd where containers launched through containerd’s CRI implementation. A remote attacker can bypass any policy-based enforcement on container setup and access the read-only copies of arbitrary files and directories on the host.

Mitigation
Install updates from vendor's website.

Vulnerable software versions

containerd: 1.5.0 - 1.5.9, 1.4.0 - 1.4.12, 1.3.0 - 1.3.10, 1.2.0 - 1.2.14, 1.1.0 - 1.1.8, 1.0.0 - 1.0.3


CPE

External links
http://github.com/containerd/containerd/releases/tag/v1.6.1
http://github.com/containerd/containerd/security/advisories/GHSA-crp2-qrr5-8pq7
http://github.com/containerd/containerd/releases/tag/v1.5.10
http://github.com/containerd/containerd/releases/tag/v1.4.13


Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?


Latest bulletins with this vulnerability