#VU61284 Out-of-bounds write


Published: 2022-03-14

Vulnerability identifier: #VU61284

Vulnerability risk: High

CVSSv3.1:

CVE-ID: CVE-2022-23943

CWE-ID: CWE-787

Exploitation vector: Network

Exploit availability: No

Vulnerable software:
Apache HTTP Server
Server applications / Web servers

Vendor: Apache Foundation

Description

The vulnerability allows a remote attacker to compromise vulnerable system.

The vulnerability exists due to a boundary error when processing untrusted input in mod_sed. A remote attacker can trigger out-of-bounds write and execute arbitrary code on the target system.

Mitigation
Install updates from vendor's website.

Vulnerable software versions

Apache HTTP Server: 2.4.0 - 2.4.52


CPE

External links
http://downloads.apache.org/httpd/CHANGES_2.4.53


Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?


Latest bulletins with this vulnerability