#VU63094 Infinite loop in pjsip


Published: 2022-05-12

Vulnerability identifier: #VU63094

Vulnerability risk: Medium

CVSSv3.1:

CVE-ID: CVE-2022-24763

CWE-ID: CWE-835

Exploitation vector: Network

Exploit availability: No

Vulnerable software:
pjsip
Universal components / Libraries / Libraries used by multiple products

Vendor: pjsip

Description

The vulnerability allows a remote attacker to perform a denial of service (DoS) attack.

The vulnerability exists due to infinite loop within XML parsing. A remote attacker can consume all available system resources and cause denial of service conditions.

Mitigation
Install updates from vendor's website.

Vulnerable software versions

pjsip: 2.0 - 2.12


CPE

External links
http://github.com/pjsip/pjproject/security/advisories/GHSA-5x45-qp78-g4p4
http://github.com/pjsip/pjproject/commit/856f87c2e97a27b256482dbe0d748b1194355a21


Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?


Latest bulletins with this vulnerability