#VU63145 OS Command Injection


Published: 2022-05-14 | Updated: 2022-06-15

Vulnerability identifier: #VU63145

Vulnerability risk: High

CVSSv3.1: 9.4 [CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H/E:H/RL:O/RC:C]

CVE-ID: CVE-2022-30525

CWE-ID: CWE-78

Exploitation vector: Network

Exploit availability: Yes

Vulnerable software:
USG FLEX 100W
Hardware solutions / Firmware
USG FLEX 200
Hardware solutions / Firmware
USG FLEX 500
Hardware solutions / Firmware
USG FLEX 700
Hardware solutions / Firmware
USG FLEX 50W
Hardware solutions / Firmware
USG20W-VPN
Hardware solutions / Firmware
ATP series
Hardware solutions / Routers for home users
VPN series
Client/Desktop applications / Antivirus software/Personal firewalls

Vendor: ZyXEL Communications Corp.

Description

The vulnerability allows a remote attacker to execute arbitrary shell commands on the target system.

The vulnerability exists due to improper input validation in the CGI program. A remote unauthenticated attacker can pass specially crafted data to the application and execute arbitrary OS commands on the target system.

Successful exploitation of this vulnerability may result in complete compromise of vulnerable system.

Mitigation
Install updates from vendor's website.

Vulnerable software versions

USG FLEX 100W: 5.00 - 5.21 Patch 1

USG FLEX 200: 5.00 - 5.21 Patch 1

USG FLEX 500: 5.00 - 5.21 Patch 1

USG FLEX 700: 5.00 - 5.21 Patch 1

USG FLEX 50W: 5.10 - 5.21 Patch 1

USG20W-VPN: 5.10 - 5.21 Patch 1

ATP series: 5.10 - 5.21 Patch 1

VPN series: 4.60 - 5.21 Patch 1


CPE

External links
http://www.zyxel.com/support/Zyxel-security-advisory-for-OS-command-injection-vulnerability-of-firewalls.shtml


Q & A

Can this vulnerability be exploited remotely?

Yes. This vulnerability can be exploited by a remote non-authenticated attacker via the Internet.

Is there known malware, which exploits this vulnerability?

Yes. This vulnerability is being exploited in the wild.


Latest bulletins with this vulnerability