#VU63170 Link following


Published: 2022-05-13

Vulnerability identifier: #VU63170

Vulnerability risk: Low

CVSSv3.1: 7.1 [CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H/E:U/RL:U/RC:C]

CVE-ID: CVE-2021-27116

CWE-ID: CWE-59

Exploitation vector: Local

Exploit availability: No

Vulnerable software:
Beego
Web applications / Modules and components for CMS

Vendor: beego Framework

Description

The vulnerability allows a local user to compromise the target system.

The vulnerability exists due to link following issue in file profile.go in function MemProf. A local user can gain elevated privileges on the target system.

Mitigation
Cybersecurity Help is currently unaware of any official solution to address this vulnerability.

Vulnerable software versions

Beego: 0.6.0 - 2.0.2


CPE

External links
http://github.com/beego/beego/issues/4484


Q & A

Can this vulnerability be exploited remotely?

No. This vulnerability can be exploited locally. The attacker should have authentication credentials and successfully authenticate on the system.

Is there known malware, which exploits this vulnerability?

No. We are not aware of malware exploiting this vulnerability.


Latest bulletins with this vulnerability