#VU63428 Use-after-free


Published: 2022-05-19

Vulnerability identifier: #VU63428

Vulnerability risk: Low

CVSSv3.1:

CVE-ID: CVE-2022-1048

CWE-ID: CWE-416

Exploitation vector: Local

Exploit availability: No

Vulnerable software:
Linux kernel
Operating systems & Components / Operating system

Vendor:

Description

The vulnerability allows a local user to execute arbitrary code with elevated privileges.

The vulnerability exists due to a use-after-free error in the Linux kernel’s sound subsystem in the way a user triggers concurrent calls of PCM hw_params. A local user can execute arbitrary code with elevated privileges and perform a denial-of-service attack.

Mitigation
Install updates from vendor's website.

Vulnerable software versions


External links
http://lore.kernel.org/lkml/20220322170720.3529-5-tiwai@suse.de/T/#m1d3b791b815556012c6be92f1c4a7086b854f7f3
http://bugzilla.redhat.com/show_bug.cgi?id=2066706
http://www.debian.org/security/2022/dsa-5127


Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?


Latest bulletins with this vulnerability