#VU63827 Use-after-free in MariaDB


Published: 2022-05-31 | Updated: 2022-05-31

Vulnerability identifier: #VU63827

Vulnerability risk: Medium

CVSSv3.1:

CVE-ID: CVE-2021-46669

CWE-ID: CWE-416

Exploitation vector: Network

Exploit availability: No

Vulnerable software:
MariaDB
Operating systems & Components / Operating system package or component

Vendor: Debian

Description

The vulnerability allows a remote attacker to perform a denial of service attack.

The vulnerability exists due to a use-after-free error in the convert_const_to_int() function when processing BIGINT data type. A remote attacker can trigger use-after-free error and perform a denial of service attack.

Mitigation
Install updates from vendor's website.

Vulnerable software versions

MariaDB: 10.2.0 - 10.2.43, 10.3.0 - 10.3.34, 10.4.0 - 10.4.24, 10.5.0 - 10.5.15, 10.6.0 - 10.6.7, 10.7.1 - 10.7.3


CPE

External links
http://jira.mariadb.org/browse/MDEV-25638
http://security.netapp.com/advisory/ntap-20220221-0002/
http://mariadb.com/kb/en/security/
http://bugzilla.redhat.com/show_bug.cgi?id=2050034


Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?


Latest bulletins with this vulnerability