#VU64082 Use-after-free


Published: 2022-06-08

Vulnerability identifier: #VU64082

Vulnerability risk: Low

CVSSv3.1:

CVE-ID: CVE-2022-1734

CWE-ID: CWE-416

Exploitation vector: Local

Exploit availability: No

Vulnerable software:
Linux kernel
Operating systems & Components / Operating system

Vendor: Linux Foundation

Description

The vulnerability allows a local user to escalate privileges on the system.

The vulnerability exists due to Marvell NFC device driver implementation in the Linux kernel did not properly perform memory cleanup operations in some situations. A local user can trigger use-after-free to escalate privileges on the system.

Mitigation
Install updates from vendor's website.

Vulnerable software versions

Linux kernel: All versions


CPE

External links
http://github.com/torvalds/linux/commit/d270453a0d9ec10bb8a802a142fb1b3601a83098
http://www.openwall.com/lists/oss-security/2022/06/05/4
http://bugzilla.redhat.com/show_bug.cgi?id=2086766


Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?


Latest bulletins with this vulnerability