#VU64227 Embedded malicious code (backdoor) in api-res-py


Published: 2022-06-13

Vulnerability identifier: #VU64227

Vulnerability risk: High

CVSSv3.1:

CVE-ID: CVE-2022-31313

CWE-ID: CWE-506

Exploitation vector: Network

Exploit availability: No

Vulnerable software:
api-res-py
Web applications / Modules and components for CMS

Vendor: rakeshrkz7

Description

The vulnerability allows a remote attacker to gain unauthorized access to the application.

The vulnerability exists due to a backdoor issue within the presence of malicious "request" dependency that allows a remote attacker to gain unauthorized access to the application.

Mitigation
Cybersecurity Help is currently unaware of any official solution to address this vulnerability.

Vulnerable software versions

api-res-py: 0.1


CPE

External links
http://github.com/rakeshrkz7/as_api_res/issues/1
http://pypi.doubanio.com/simple/request
http://pypi.org/project/api-res-py/


Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?


Latest bulletins with this vulnerability