#VU64416 Improper Preservation of Permissions


Published: 2022-06-15 | Updated: 2022-10-19

Vulnerability identifier: #VU64416

Vulnerability risk: Low

CVSSv3.1:

CVE-ID: CVE-2021-41091

CWE-ID: CWE-281

Exploitation vector: Local

Exploit availability: No

Vulnerable software:
moby
Server applications / Virtualization software

Vendor: Moby project

Description

The vulnerability allows a local user to escalate privileges on the system.

The vulnerability exists due to application does not properly impose security restrictions, which leads to security restrictions bypass and privilege escalation.

Mitigation
Install updates from vendor's website.

Vulnerable software versions

moby: 20.10.0 - 20.10.8


CPE

External links
http://github.com/moby/moby/commit/f0ab919f518c47240ea0e72d0999576bb8008e64
http://github.com/moby/moby/security/advisories/GHSA-3fwx-pjgw-3558
http://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/ZNFADTCHHYWVM6W4NJ6CB4FNFM2VMBIB/
http://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/B5Q6G6I4W5COQE25QMC7FJY3I3PAYFBB/
http://cert-portal.siemens.com/productcert/pdf/ssa-222547.pdf


Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?


Latest bulletins with this vulnerability