#VU64685 Improper Verification of Cryptographic Signature in cURL


Published: 2022-06-27

Vulnerability identifier: #VU64685

Vulnerability risk: Medium

CVSSv3.1:

CVE-ID: CVE-2022-32208

CWE-ID: CWE-347

Exploitation vector: Network

Exploit availability: No

Vulnerable software:
cURL
Client/Desktop applications / Other client software

Vendor: curl.haxx.se

Description

The vulnerability allows a remote attacker to perform MitM attack.

The vulnerability exists due to improper handling of message verification failures when performing FTP transfers secured by krb5. A remote attacker can perform MitM attack and manipulate data.

Mitigation
Install updates from vendor's website.

Vulnerable software versions

cURL: 7.16.4 - 7.83.1


CPE

External links
http://curl.haxx.se/docs/CVE-2022-32208.html


Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?


Latest bulletins with this vulnerability