#VU66024 Buffer overflow in MariaDB


Published: 2022-08-03 | Updated: 2022-08-16

Vulnerability identifier: #VU66024

Vulnerability risk: Low

CVSSv3.1:

CVE-ID: CVE-2022-32084

CWE-ID: CWE-119

Exploitation vector: Local

Exploit availability: No

Vulnerable software:
MariaDB
Server applications / Database software

Vendor: MariaDB Foundation

Description

The vulnerability allows a local user to escalate privileges on the system.

The vulnerability exists due to a segmentation fault via the component sub_select. A local user can send a specially crafted file and escalate privileges on the system.

Mitigation
Install update from vendor's website.

Vulnerable software versions

MariaDB: 10.2.0 - 10.2.44, 10.3.0 - 10.3.35, 10.4.0 - 10.4.25, 10.5.0 - 10.5.16, 10.6.0 - 10.6.8, 10.7.0 - 10.7.4, 10.8.0 - 10.8.3, 10.9.0 - 10.9.1


CPE

External links
http://jira.mariadb.org/browse/MDEV-26427


Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?


Latest bulletins with this vulnerability