#VU66141 Heap-based buffer overflow


Published: 2022-08-05 | Updated: 2022-08-05

Vulnerability identifier: #VU66141

Vulnerability risk: Low

CVSSv3.1: 1.8 [CVSS:3.1/AV:P/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:L/E:U/RL:O/RC:C]

CVE-ID: CVE-2021-42781

CWE-ID: CWE-122

Exploitation vector: Local

Exploit availability: No

Vulnerable software:
OpenSC
Universal components / Libraries / Libraries used by multiple products

Vendor: OpenSC

Description

The vulnerability allows an attacker with physical access to perform denial of service attack.

The vulnerability exists due to a boundary error in Opensc before in pkcs15-oberthur.c. An attacker with physical access can pass specially crafted data to the application, trigger a heap-based buffer overflow and perform denial of service attack.

Mitigation
Install updates from vendor's website.

Vulnerable software versions

OpenSC: 0.2.0 - 0.21.0 rc2


CPE

External links
http://bugzilla.redhat.com/show_bug.cgi?id=2016439
http://github.com/OpenSC/OpenSC/commit/17d8980c
http://github.com/OpenSC/OpenSC/commit/5d4daf6c
http://github.com/OpenSC/OpenSC/commit/40c50a3a
http://github.com/OpenSC/OpenSC/commit/05648b06
http://github.com/OpenSC/OpenSC/commit/cae5c71f


Q & A

Can this vulnerability be exploited remotely?

No. The attacker should have physical access to the system in order to successfully exploit this vulnerability.

Is there known malware, which exploits this vulnerability?

No. We are not aware of malware exploiting this vulnerability.


Latest bulletins with this vulnerability