#VU66147 Improper Certificate Validation


Published: 2022-08-05

Vulnerability identifier: #VU66147

Vulnerability risk: Medium

CVSSv3.1: 4.2 [CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:N/E:U/RL:O/RC:C]

CVE-ID: CVE-2022-34865

CWE-ID: CWE-295

Exploitation vector: Network

Exploit availability: No

Vulnerable software:
BIG-IP
Hardware solutions / Firmware

Vendor: F5 Networks, Inc.

Description

The vulnerability allows a remote attacker to compromise the target system.

The vulnerability exists due to improper server certificate verification in the Traffic Intelligence feeds. A remote attacker can perform a man-in-the-middle (MitM) attack and read and/or modify data in transit that is used for Traffic Intelligence feeds.

Mitigation
Install updates from vendor's website.

Vulnerable software versions

BIG-IP: 13.1.0 - 15.1.6


CPE

External links
http://support.f5.com/csp/article/K25046752


Q & A

Can this vulnerability be exploited remotely?

Yes. This vulnerability can be exploited by a remote non-authenticated attacker via the Internet.

Is there known malware, which exploits this vulnerability?

No. We are not aware of malware exploiting this vulnerability.


Latest bulletins with this vulnerability