#VU66422 Out-of-bounds write


Published: 2022-08-12

Vulnerability identifier: #VU66422

Vulnerability risk: High

CVSSv3.1:

CVE-ID: CVE-2022-29536

CWE-ID: CWE-787

Exploitation vector: Network

Exploit availability: No

Vulnerable software:
GNOME Web (Epiphany)
Client/Desktop applications / Web browsers

Vendor: Gnome Development Team

Description

The vulnerability allows a remote attacker to compromise vulnerable system.

The vulnerability exists due to a boundary error when processing a long page title in the ephy_string_shorten() function in the UI process. A remote attacker can create a specially crafted website, trick the victim into visiting it, trigger an out-of-bounds write and execute arbitrary code on the target system.

Mitigation
Install updates from vendor's website.

Vulnerable software versions

GNOME Web (Epiphany): 41.0 - 41.3


CPE

External links
http://gitlab.gnome.org/GNOME/epiphany/-/merge_requests/1106
http://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/U5K5UPNHVWXDPSMBNSB2645MD2N5CXQS/
http://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/GLLDMY4JYDZTMZSCPSY23K5YW3SQYUR6/
http://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/N7YWVIUGFRA6GOE3QAPSJJ6EL3DJG5NX/


Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?


Latest bulletins with this vulnerability