#VU6674 Information disclosure


Published: 2017-05-24 | Updated: 2018-07-25

Vulnerability identifier: #VU6674

Vulnerability risk: Low

CVSSv3.1:

CVE-ID: CVE-2017-5647

CWE-ID: CWE-200

Exploitation vector: Network

Exploit availability: No

Vulnerable software:
Apache Tomcat
Server applications / Web servers

Vendor: Apache Foundation

Description
The vulnerability allows a remote attacker to obtain potentially sensitive information on the target system.

The weakness exists in the handling of the pipelined requests when send file was used resulted in the pipelined request being lost when send file processing of the previous request completed. A remote attacker can cause responses to appear to be sent for the wrong request.

Mitigation
The vulnerability is addressed in the versions 6.0.53, 7.0.77, 9.0.0 M19.

Vulnerable software versions

Apache Tomcat: 6.0.0 - 6.0.52, 9.0.0-M1 - 9.0.0-M18, 7.0.0 - 7.0.87


CPE

External links
http://tomcat.apache.org/security-6.html#Fixed_in_Apache_Tomcat_6.0.53
http://tomcat.apache.org/security-7.html#Fixed_in_Apache_Tomcat_7.0.77
http://tomcat.apache.org/security-9.html#Fixed_in_Apache_Tomcat_9.0.0.M19


Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?


Latest bulletins with this vulnerability