#VU67551 Session Fixation in Apache Airflow


Published: 2022-09-21

Vulnerability identifier: #VU67551

Vulnerability risk: High

CVSSv3.1:

CVE-ID: CVE-2022-38054

CWE-ID: CWE-384

Exploitation vector: Network

Exploit availability: No

Vulnerable software:
Apache Airflow
Web applications / Modules and components for CMS

Vendor: Apache Foundation

Description

The vulnerability allows a remote attacker to compromise the affected application.

The vulnerability exists due to incorrect processing of authentication sessions in the `database` webserver session backend. A remote attacker can perform session fixation attacks and compromise the web application.

Mitigation
Install updates from vendor's website.

Vulnerable software versions

Apache Airflow: 2.3.0 - 2.3.3


CPE

External links
http://lists.apache.org/thread/rsd3h89xdp16rg0ltovx3m7q3ypkxsbb
http://www.openwall.com/lists/oss-security/2022/09/02/1


Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?


Latest bulletins with this vulnerability