#VU69583 Input validation error in Nokogiri


Published: 2022-11-24

Vulnerability identifier: #VU69583

Vulnerability risk: Medium

CVSSv3.1:

CVE-ID: CVE-2022-29181

CWE-ID: CWE-20

Exploitation vector: Network

Exploit availability: No

Vulnerable software:
Nokogiri
Universal components / Libraries / Programming Languages & Components

Vendor: nokogiri.org

Description

The vulnerability allows a remote attacker to perform a denial of service (DoS) attack.

The vulnerability exists due to insufficient validation of user-supplied input passed into the XML and HTML4 SAX parsers. A remote attacker can pass specially crafted input to the application and perform a denial of service (DoS) attack.

Mitigation
Install updates from vendor's website.

Vulnerable software versions

Nokogiri: 1.4.4 - 1.13.5


CPE

External links
http://github.com/sparklemotion/nokogiri/releases/tag/v1.13.6
http://github.com/sparklemotion/nokogiri/security/advisories/GHSA-xh29-r2w5-wx8m
http://github.com/sparklemotion/nokogiri/commit/db05ba9a1bd4b90aa6c76742cf6102a7c7297267
http://securitylab.github.com/advisories/GHSL-2022-031_GHSL-2022-032_Nokogiri/
http://security.gentoo.org/glsa/202208-29


Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?


Latest bulletins with this vulnerability