#VU7118 NULL pointer dereference


Published: 2017-06-20 | Updated: 2017-06-20

Vulnerability identifier: #VU7118

Vulnerability risk: Medium

CVSSv3.1:

CVE-ID: CVE-2017-7659

CWE-ID: CWE-476

Exploitation vector: Network

Exploit availability: No

Vulnerable software:
Apache HTTP Server
Server applications / Web servers

Vendor: Apache Foundation

Description

The vulnerability allows a remote attacker to perform denial of service attack.

The vulnerability exists due to a NULL pointer dereference error within mod_http2. A remote attacker can send a specially crafted HTTP/2 request and crash the affected process.

Successful exploitation of the vulnerability result in denial of service (DoS) attack.

Mitigation
Update to version 2.4.26.

Vulnerable software versions

Apache HTTP Server: 2.4.24 - 2.4.25


CPE

External links
http://httpd.apache.org/security/vulnerabilities_24.html


Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?


Latest bulletins with this vulnerability