#VU7874 Denial of service in PostgreSQL


Published: 2017-08-15 | Updated: 2018-02-09

Vulnerability identifier: #VU7874

Vulnerability risk: Low

CVSSv3.1:

CVE-ID: CVE-2017-7548

CWE-ID: CWE-284

Exploitation vector: Network

Exploit availability: No

Vulnerable software:
PostgreSQL
Server applications / Database software

Vendor: PostgreSQL Global Development Group

Description
The vulnerability allows a remote authenticated attacker to cause DoS condition on the target system.

The weakness exists due to an access control flaw in the lo_put() function to change the data in a large object. A remote attacker can cause the application to crash.

Mitigation
The vulnerability is addressed in the following versions: 9.2.22, 9.3.18, 9.4.13, 9.5.8, 9.6.4.

Vulnerable software versions

PostgreSQL: 9.2.1 - 9.2.21, 9.3.1 - 9.3.17, 9.4.0 - 9.4.12, 9.5.0 - 9.5.7, 9.6.0 - 9.6.3


CPE

External links
http://www.postgresql.org/about/news/1772/


Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?


Latest bulletins with this vulnerability