#VU9690 Buffer over-read in Libxml2


Published: 2017-12-19

Vulnerability identifier: #VU9690

Vulnerability risk: Low

CVSSv3.1:

CVE-ID: CVE-2017-8872

CWE-ID: CWE-126

Exploitation vector: Network

Exploit availability: No

Vulnerable software:
Libxml2
Universal components / Libraries / Libraries used by multiple products

Vendor: Gnome Development Team

Description
The vulnerability allows a remote attacker to obtain potentially sensitive information or cause DoS condition on the target system.

The weakness exists in the htmlParseTryOrFinish function of XMLSoft libxml2 due to buffer over-read condition in the HTMLparser.c source code. A remote attacker can send a specially crafted XML file, trick the victim into opening it and read arbitrary data or cause the service to crash.

Successful exploitation of the vulnerability results in denial of service.

Mitigation
Install update from vendor's website.

Vulnerable software versions

Libxml2: 2.9.4


CPE

External links
http://www.vuxml.org/freebsd/76e59f55-4f7a-4887-bcb0-11604004163a.html


Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?


Latest bulletins with this vulnerability