#VU9717 Buffer over-read


Published: 2017-12-22

Vulnerability identifier: #VU9717

Vulnerability risk: Low

CVSSv3.1:

CVE-ID: CVE-2017-11147

CWE-ID: CWE-126

Exploitation vector: Network

Exploit availability: No

Vulnerable software:
PHP
Universal components / Libraries / Scripting languages

Vendor: PHP Group

Description
The vulnerability allows a remote attacker to cause DoS condition or obtain potentially sensitive information on the target system.

The weakness exists due to a flaw in the PHAR archive handler. A remote attacker can supply malicious archive files, trigger buffer over-read in the phar_parse_pharfile function in ext/phar/phar.c and cause the PHP interpreter to crash or potentially disclose information.

Mitigation
Update to version 5.6.30 or 7.0.15.

Vulnerable software versions

PHP: 5.6.0 - 5.6.29, 5.5.0 - 5.5.38, 5.4.0 - 5.4.44, 5.1 - 5.1.6, 5.3.0 - 5.3.27, 5.2.0 - 5.2.17, 5.0 - 5.0.5, 7.0.0 - 7.0.14


CPE

External links
http://bugs.php.net/bug.php?id=73773


Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?


Latest bulletins with this vulnerability