XXE in ManageEngine AssetExplorer



Published: 2022-11-24
Risk Low
Patch available YES
Number of vulnerabilities 1
CVE-ID CVE-2022-40771
CWE-ID CWE-611
Exploitation vector Network
Public exploit N/A
Vulnerable software
Subscribe
ManageEngine AssetExplorer
Web applications / Remote management & hosting panels

Vendor Zoho Corporation

Security Bulletin

This security bulletin contains one low risk vulnerability.

1) XML External Entity injection

EUVDB-ID: #VU69580

Risk: Low

CVSSv3.1:

CVE-ID: CVE-2022-40771

CWE-ID: CWE-611 - Improper Restriction of XML External Entity Reference ('XXE')

Exploit availability: No

Description

The vulnerability allows a remote attacker to gain access to sensitive information.

The vulnerability exists due to insufficient validation of user-supplied XML input when integrating with Analytics Plus. A remote attacker can pass a specially crafted XML code to the affected application and view contents of arbitrary files on the system or initiate requests to external systems.

Successful exploitation of the vulnerability may allow an attacker to view contents of arbitrary file on the server or perform network scanning of internal and external infrastructure.

Mitigation

Install update from vendor's website.

Vulnerable software versions

ManageEngine AssetExplorer: 6000 - 6980


CPE2.3 External links

http://www.manageengine.com/products/service-desk/CVE-2022-40771.html

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?



###SIDEBAR###