Use-after-free in Linux kernel - CVE-2019-9003

 

Use-after-free in Linux kernel - CVE-2019-9003

Published: February 22, 2019 / Updated: July 17, 2020


Vulnerability identifier: #VU31153
CSH Severity: Medium
CVSS v4: 8.7 [CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N]
CVE-ID: CVE-2019-9003
CWE-ID: CWE-416
Exploitation vector: Remote access
Exploit availability: No public exploit available

Vulnerability details

The vulnerability allows a remote non-authenticated attacker to perform a denial of service (DoS) attack.

In the Linux kernel before 4.20.5, attackers can trigger a drivers/char/ipmi/ipmi_msghandler.c use-after-free and OOPS by arranging for certain simultaneous execution of the code, as demonstrated by a "service ipmievd restart" loop.


Affected software

Linux kernel
Ubuntu
linux (Ubuntu package)
linux-gcp (Ubuntu package)
linux-aws (Ubuntu package)
linux-kvm (Ubuntu package)
linux-azure (Ubuntu package)

How to mitigate CVE-2019-9003

Install update from vendor's website.

Linux kernel - update to 4.20.5
linux (Ubuntu package) - update to 4.18.0-17.18
linux-gcp (Ubuntu package) - update to 4.18.0-1008.9
linux-aws (Ubuntu package) - update to 4.18.0-1012.14
linux-kvm (Ubuntu package) - update to 4.18.0-1009.9
linux-azure (Ubuntu package) - update to 4.18.0-1014.14

External References

Related Security Bulletins