Permissions, Privileges, and Access Controls in Linux kernel - CVE-2014-4943
Published: July 19, 2014 / Updated: August 11, 2020
Vulnerability identifier: #VU41467
CSH Severity: High
CVSS v4: 8.6 [CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N]
CVE-ID: CVE-2014-4943
CWE-ID: CWE-264
Exploitation vector: Remote access
Exploit availability:
Public exploit is available
Vulnerability details
The vulnerability allows a remote non-authenticated attacker to execute arbitrary code.
The PPPoL2TP feature in net/l2tp/l2tp_ppp.c in the Linux kernel through 3.15.6 allows local users to gain privileges by leveraging data-structure differences between an l2tp socket and an inet socket.
Affected software
Linux kernel
Ubuntu
linux (Ubuntu package)
linux-image-2.6.32-368-ec2 (Ubuntu package)
linux-image-3.5.0-54-generic (Ubuntu package)
linux-lts-saucy (Ubuntu package)
linux-lts-trusty (Ubuntu package)
Ubuntu
linux (Ubuntu package)
linux-image-2.6.32-368-ec2 (Ubuntu package)
linux-image-3.5.0-54-generic (Ubuntu package)
linux-lts-saucy (Ubuntu package)
linux-lts-trusty (Ubuntu package)
How to mitigate CVE-2014-4943
Install update from vendor's website.
linux (Ubuntu package) - addressed in versions 2.6.32-64.128, 3.2.0-67.101, 3.13.0-32.57
linux-image-2.6.32-368-ec2 (Ubuntu package) - update to 2.6.32-368.84
linux-image-3.5.0-54-generic (Ubuntu package) - update to 3.5.0-54.81~precise1
linux-lts-saucy (Ubuntu package) - update to 3.11.0-26.45~precise1
linux-lts-trusty (Ubuntu package) - update to 3.13.0-32.57~precise1
linux-image-2.6.32-368-ec2 (Ubuntu package) - update to 2.6.32-368.84
linux-image-3.5.0-54-generic (Ubuntu package) - update to 3.5.0-54.81~precise1
linux-lts-saucy (Ubuntu package) - update to 3.11.0-26.45~precise1
linux-lts-trusty (Ubuntu package) - update to 3.13.0-32.57~precise1
Links to Public Exploits and PoC-codes
External References
- http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commit;h=3cf521f7dc87c031617fd47e4b7aa2593c2f3daf
- http://linux.oracle.com/errata/ELSA-2014-0924.html
- http://linux.oracle.com/errata/ELSA-2014-3047.html
- http://linux.oracle.com/errata/ELSA-2014-3048.html
- http://lists.opensuse.org/opensuse-security-announce/2014-10/msg00006.html
- http://lists.opensuse.org/opensuse-security-announce/2014-10/msg00007.html
- http://lists.opensuse.org/opensuse-security-announce/2015-03/msg00010.html
- http://lists.opensuse.org/opensuse-security-announce/2015-03/msg00025.html
- http://openwall.com/lists/oss-security/2014/07/17/1
- http://osvdb.org/show/osvdb/109277
- http://rhn.redhat.com/errata/RHSA-2014-1025.html
- http://secunia.com/advisories/59790
- http://secunia.com/advisories/60011
- http://secunia.com/advisories/60071
- http://secunia.com/advisories/60220
- http://secunia.com/advisories/60380
- http://secunia.com/advisories/60393
- http://www.debian.org/security/2014/dsa-2992
- http://www.exploit-db.com/exploits/36267
- http://www.securitytracker.com/id/1030610
- https://bugzilla.redhat.com/show_bug.cgi?id=1119458
- https://exchange.xforce.ibmcloud.com/vulnerabilities/94665
- https://github.com/torvalds/linux/commit/3cf521f7dc87c031617fd47e4b7aa2593c2f3daf