Information exposure in Linux kernel - CVE-2014-3917

 

Information exposure in Linux kernel - CVE-2014-3917

Published: June 5, 2014 / Updated: July 15, 2021


Vulnerability identifier: #VU92805
CSH Severity: Low
CVSS v4: 4.8 [CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:L/VI:N/VA:L/SC:N/SI:N/SA:N]
CVE-ID: CVE-2014-3917
CWE-ID: CWE-200
Exploitation vector: Local access
Exploit availability: No public exploit available

Vulnerability details

The vulnerability allows a local user to read memory contents or crash the application.

kernel/auditsc.c in the Linux kernel through 3.14.5, when CONFIG_AUDITSYSCALL is enabled with certain syscall rules, allows local users to obtain potentially sensitive single-bit values from kernel memory or cause a denial of service (OOPS) via a large value of a syscall number.


Affected software

Linux kernel
Ubuntu
linux (Ubuntu package)
linux-image-2.6.32-368-ec2 (Ubuntu package)
linux-image-3.5.0-54-generic (Ubuntu package)
linux-lts-saucy (Ubuntu package)
linux-lts-trusty (Ubuntu package)

How to mitigate CVE-2014-3917

Install update from vendor's repository.

linux (Ubuntu package) - addressed in versions 2.6.32-64.128, 3.2.0-68.102, 3.13.0-33.58
linux-image-2.6.32-368-ec2 (Ubuntu package) - update to 2.6.32-368.84
linux-image-3.5.0-54-generic (Ubuntu package) - update to 3.5.0-54.81~precise1
linux-lts-saucy (Ubuntu package) - update to 3.11.0-26.45~precise1
linux-lts-trusty (Ubuntu package) - update to 3.13.0-33.58~precise1

External References

Related Security Bulletins