#VU25501 Use-after-free


Published: 2020-02-21 | Updated: 2020-03-17

Vulnerability identifier: #VU25501

Vulnerability risk: High

CVSSv3.1:

CVE-ID: CVE-2020-8945

CWE-ID: CWE-416

Exploitation vector: Network

Exploit availability: No

Vulnerable software:
gpgme
Web applications / Modules and components for CMS

Vendor: James Fargher

Description

The vulnerability allows a remote attacker to compromise vulnerable system.

The vulnerability exists due to a use-after-free error, as demonstrated by use for container image pulls by Docker or CRI-O. A remote attacker can crash the target system, or cause potential code execution for Go applications that use this library under certain conditions during GPG signature verification.

Mitigation
Install updates from vendor's website.

Vulnerable software versions

gpgme: 0.1.0


CPE

External links
http://bugzilla.redhat.com/show_bug.cgi?id=1795838
http://github.com/containers/image/commit/4c7a23f82ef09127b0ff28366d1cf31316dd6cc1
http://github.com/proglottis/gpgme/compare/v0.1.0...v0.1.1
http://github.com/proglottis/gpgme/pull/23


Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?


Latest bulletins with this vulnerability