#VU53202 Command Injection in Lodash


Published: 2021-05-12

Vulnerability identifier: #VU53202

Vulnerability risk: Medium

CVSSv3.1:

CVE-ID: CVE-2021-23337

CWE-ID: CWE-77

Exploitation vector: Network

Exploit availability: No

Vulnerable software:
Lodash
Web applications / JS libraries

Vendor: Lodash

Description

The vulnerability allows a remote user to execute arbitrary commands on the system.

The vulnerability exists due to improper input validation when processing templates. A remote privileged user can inject and execute arbitrary commands on the system.

Mitigation
Install updates from vendor's website.

Vulnerable software versions

Lodash: 0.1.0 - 4.17.20


CPE

External links
http://github.com/lodash/lodash/blob/ddfd9b11a0126db2302cb70ec9973b66baec0975/lodash.js%23L14851
http://security.netapp.com/advisory/ntap-20210312-0006/
http://snyk.io/vuln/SNYK-JAVA-ORGFUJIONWEBJARS-1074932
http://snyk.io/vuln/SNYK-JAVA-ORGWEBJARS-1074930
http://snyk.io/vuln/SNYK-JAVA-ORGWEBJARSBOWER-1074928
http://snyk.io/vuln/SNYK-JAVA-ORGWEBJARSBOWERGITHUBLODASH-1074931
http://snyk.io/vuln/SNYK-JAVA-ORGWEBJARSNPM-1074929
http://snyk.io/vuln/SNYK-JS-LODASH-1040724


Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?


Latest bulletins with this vulnerability