Remote code execution in UUSee UUUpgrade.ocx ActiveX control



Published: 2008-06-27
Risk Critical
Patch available YES
Number of vulnerabilities 1
CVE-ID CVE-2008-7168
CWE-ID CWE-618
Exploitation vector Network
Public exploit This vulnerability is being exploited in the wild.
Vulnerable software
Subscribe
UUSee
Client/Desktop applications / Multimedia software

UUSee UUUpgrade ActiveX control
Client/Desktop applications / Plugins for browsers, ActiveX components

Vendor UUSEE

Security Bulletin

This security bulletin contains one critical risk vulnerability.

1) Unsafe ActiveX method

EUVDB-ID: #VU6167

Risk: Critical

CVSSv3.1:

CVE-ID: CVE-2008-7168

CWE-ID: CWE-618 - Exposed Unsafe ActiveX Method

Exploit availability: Yes

Description

The vulnerability allows a remote attacker to execute arbitrary code on the target system.

The vulnerability exists due to insufficient validation of arguments passed to the "Update()"  method in UUUpgrade.ocx ActiveX control. A remote attacker can trick the victim to visit a specially crafted website and upload malicious file into arbitrary location on victim's computer.

Successful exploitation of the vulnerability may allow an attacker to compromise vulnerable system.

Note: this vulnerability was being actively exploited in the wild.

Mitigation

Install the latest version from vendor's website.

Vulnerable software versions

UUSee: 2008

UUSee UUUpgrade ActiveX control: 3.0.2.12


CPE2.3 External links

http://www.exploit-db.com/exploits/31980/
http://www.securityfocus.com/bid/29963/info

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?



###SIDEBAR###