Slackware Linux update for php



Published: 2016-12-13
Risk Low
Patch available YES
Number of vulnerabilities 3
CVE-ID CVE-2016-9933
CVE-2016-9934
CVE-2016-9935
CWE-ID CWE-400
CWE-476
CWE-125
Exploitation vector Network
Public exploit N/A
Vulnerable software
Subscribe
Slackware Linux
Operating systems & Components / Operating system

Vendor Slackware

Security Bulletin

This security bulletin contains information about 3 vulnerabilities.

1) Resource exhaustion

EUVDB-ID: #VU12901

Risk: Low

CVSSv3.1:

CVE-ID: CVE-2016-9933

CWE-ID: CWE-400 - Resource exhaustion

Exploit availability: No

Description

The vulnerability allows a remote attacker to cause DoS condition on the target system.

The weakness exists in the gdImageFillToBorder function in gd.c due to stack consumption. A remote attacker can submit a specially crafted imagefilltoborder call that triggers use of a negative color value and cause the service to crash.

Mitigation

Update the affected package php.

Vulnerable software versions

Slackware Linux: 14.0 - 14.2


CPE2.3 External links

http://www.slackware.com/security/viewer.php?l=slackware-security&y=2016&m=slackware-security.429698

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?

2) NULL pointer dereference

EUVDB-ID: #VU12902

Risk: Low

CVSSv3.1:

CVE-ID: CVE-2016-9934

CWE-ID: CWE-476 - NULL Pointer Dereference

Exploit availability: No

Description

The vulnerability allows a remote attacker to cause DoS condition on the target system.

The weakness exists in ext/wddx/wddx.c due to NULL pointer dereference. A remote attacker can submit crafted serialized data in a wddxPacket XML document, as demonstrated by a PDORow string, and cause the service to crash.

Mitigation

Update the affected package php.

Vulnerable software versions

Slackware Linux: 14.0 - 14.2


CPE2.3 External links

http://www.slackware.com/security/viewer.php?l=slackware-security&y=2016&m=slackware-security.429698

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?

3) Out-of-bounds read

EUVDB-ID: #VU12903

Risk: Low

CVSSv3.1:

CVE-ID: CVE-2016-9935

CWE-ID: CWE-125 - Out-of-bounds read

Exploit availability: No

Description

The vulnerability allows a remote attacker to cause DoS condition on the target system.

The weakness exists in the php_wddx_push_element function in ext/wddx/wddx.c due to out-of-bounds read. A remote attacker can submit an empty boolean element in a wddxPacket XML document and cause the service to crash.

Mitigation

Update the affected package php.

Vulnerable software versions

Slackware Linux: 14.0 - 14.2


CPE2.3 External links

http://www.slackware.com/security/viewer.php?l=slackware-security&y=2016&m=slackware-security.429698

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?



###SIDEBAR###