Denial of service in OpenLDAP



Published: 2017-05-31
Risk Low
Patch available YES
Number of vulnerabilities 1
CVE-ID CVE-2017-9287
CWE-ID CWE-415
Exploitation vector Network
Public exploit N/A
Vulnerable software
Subscribe
OpenLDAP
Server applications / Directory software, identity management

Vendor OpenLDAP.org

Security Bulletin

This security bulletin contains one low risk vulnerability.

1) Double free error

EUVDB-ID: #VU6842

Risk: Low

CVSSv3.1:

CVE-ID: CVE-2017-9287

CWE-ID: CWE-415 - Double Free

Exploit availability: No

Description

The vulnerability allows a remote authenticated attacker to perform a denial of service (DoS) attack.

The vulnerability exists due to a double free error within servers/slapd/back-mdb/search.c when processing search requests, which include the Paged Results control with a page size of 0. A remote authenticated attacker can issue a directory search and crash the slapd daemon.

Successful exploitation of the vulnerability may allow a remote authenticated attacker to perform a denial of service (DoS) attack.

Mitigation

Update to version 2.4.45.

Vulnerable software versions

OpenLDAP: 1.0 - 2.4.44


CPE2.3 External links

http://www.openldap.org/its/?findid=8655
http://www.openldap.org/devel/gitweb.cgi?p=openldap.git;a=commit;h=0cee1ffb6021b1aae3fcc9581699da1c85a6dd6e
http://www.openldap.org/software/release/changes.html

Q & A

Can this vulnerability be exploited remotely?

How the attacker can exploit this vulnerability?

Is there known malware, which exploits this vulnerability?



###SIDEBAR###