Privilege escalation in OpenType font driver in Microsoft Windows

Published: 2018-04-10 23:11:29
Severity Low
Patch available YES
Number of vulnerabilities 1
CVE ID CVE-2018-1008
CVSSv3 7.7 [CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H/E:U/RL:O/RC:C]
CWE ID CWE-119
Exploitation vector Local
Public exploit Not available
Vulnerable software Windows
Windows Server
Vulnerable software versions Windows 8.1
Windows 7
Windows 10
Windows RT 8.1
Windows Server 2012
Windows Server 2012 R2
Windows Server 2008
Windows Server 2008 R2
Windows Server 2016
Vendor URL Microsoft

Security Advisory

1) Buffer overflow

Description

The vulnerability allows a local user to elevate privileges on the system.

The vulnerability exists due to boundary error in Windows Adobe Type Manager Font Driver (ATMFD.dll). A local user can run a specially crafted application to trigger memory corruption and execute arbitrary code on the target system with elevated privileges.

Remediation

Install updates from vendor's website.

External links

https://portal.msrc.microsoft.com/en-US/security-guidance/advisory/CVE-2018-1008

Back to List