Security restrictions bypass in WhatsApp

Published: 2018-08-09 09:01:43
Severity Low
Patch available NO
Number of vulnerabilities 1
CVE ID N/A
CVSSv3 6.7 [CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L/E:U/RL:U/RC:C]
CWE ID CWE-284
Exploitation vector Network
Public exploit Not available
Vulnerable software WhatsApp
Vulnerable software versions WhatsApp -
Vendor URL WhatsApp

Security Advisory

1) Content manipulation

Description

The vulnerability allows a remote attacker to manipulate messages sent in both private and group conversations, giving attackers immense power to create and spread misinformation from what appear to be trusted sources.

The weakness exists due to an error when connecting to WhatsApp network and content decryption. A remote attacker can use the ‘quote’ feature in a group conversation to change the identity of the sender, even if that person is not a member of the group, alter the text of someone else’s reply, essentially putting words in their mouth, send a private message to another group participant that is disguised as a public message for all, so when the targeted individual responds, it’s visible to everyone in the conversation.

Remediation

Cybersecurity Help is currently unaware of any solutions addressing the vulnerability.

External links

https://research.checkpoint.com/fakesapp-a-vulnerability-in-whatsapp/

Back to List