Debian update for nginx

Published: 2018-11-09 12:57:18 | Updated: 2018-11-09 12:57:38
Severity Medium
Patch available YES
Number of vulnerabilities 3
CVE ID CVE-2018-16843
CVE-2018-16844
CVE-2018-16845
CVSSv3 5.2 [CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H/E:U/RL:O/RC:C]
5.2 [CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H/E:U/RL:O/RC:C]
5.2 [CVSS:3.0/AV:N/AC:H/PR:N/UI:R/S:U/C:L/I:N/A:H/E:U/RL:O/RC:C]
CWE ID CWE-399
CWE-125
Exploitation vector Network
Public exploit Not available
Vulnerable software Debian Linux
Vulnerable software versions Debian Linux -
Vendor URL Debian

Security Advisory

1) Resource management error

Description

The vulnerability allows a remote attacker to perform a denial of service (DoS) attack.

The vulnerability exists due to excessive memory usage when processing HTTP/2 requests within the ngx_http_v2_module module. A remote attacker can send specially crafted HTTP/2 requests to the affected web server and consume all available memory on the system and perform a denial of service (DoS) attack.

Remediation

Update the affected package to version: 1.10.3-1+deb9u2

External links

https://www.debian.org/security/2018/dsa-4335

2) Resource management error

Description

The vulnerability allows a remote attacker to perform a denial of service (DoS) attack.

The vulnerability exists due to excessive CPU usage when processing HTTP/2 requests within the ngx_http_v2_module module. A remote attacker can send specially crafted HTTP/2 requests to the affected web server and cause high CPU usage and perform a denial of service (DoS) attack.

Remediation

Update the affected package to version: 1.10.3-1+deb9u2

External links

https://www.debian.org/security/2018/dsa-4335

3) Buffer over-read

Description

The vulnerability allows a remote attacker to gain access to potentially sensitive information or trigger denial of service conditions.

The vulnerability exists due to a boundary condition when processing headers of MP4 files within the ngx_http_mp4_module module. A remote attacker can create a specially crafted MP4 file, trick the victim into uploading it on the server and trigger application crash or disclosure of the worker's process memory.

Successful exploitation of the vulnerability requires that nginx is compiled with support for ngx_http_mp4_module module (not a default configuration).

Remediation

Update the affected package to version: 1.10.3-1+deb9u2

External links

https://www.debian.org/security/2018/dsa-4335

Back to List