OpenSUSE Linux update for discount

Published: 2019-01-14 11:42:34 | Updated: 2019-01-14
Severity Low
Patch available YES
Number of vulnerabilities 2
CVE ID CVE-2018-11468
CVE-2018-12495
CVSSv3 5.7 [CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H/E:U/RL:O/RC:C]
5.7 [CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H/E:U/RL:O/RC:C]
CWE ID CWE-125
Exploitation vector Network
Public exploit N/A
Vulnerable software Opensuse
Vulnerable software versions Opensuse 15.0
Opensuse 42.3
Vendor URL Novell

Security Advisory

1) Out-of-bounds read

Description

The vulnerability allows a remote attacker to perform a denial of service (DoS) attack.

The vulnerability exists due to heap-based buffer over-read in the __mkd_trim_line function in mkdio.c in libmarkdown.a. A remote attacker can perform a denial of service via a specially crafted file.

Remediation

Update the affected packages.

External links

https://lists.opensuse.org/opensuse-security-announce/2019-01/msg00007.html

2) Out-of-bounds read

Description

The vulnerability allows a remote attacker to perform a denial of service (DoS) attack.

The vulnerability exists due to heap-based buffer over-read in the quoteblock function in markdown.c in libmarkdown.a. A remote attacker can perform a denial of service via a specially crafted file.

Remediation

Update the affected packages.

External links

https://lists.opensuse.org/opensuse-security-announce/2019-01/msg00007.html

Back to List