Multiple vulnerabilities in GnuTLS

Published: 2019-04-01 | Updated: 2019-04-01
Severity High
Patch available YES
Number of vulnerabilities 2
CVE ID CVE-2019-3829
CVE-2019-3836
CWE ID CWE-415
CWE-119
Exploitation vector Network
Public exploit N/A
Vulnerable software GnuTLS Subscribe
Vendor GnuTLS

Security Advisory

1) Double free

Severity: High

CVSSv3: 7.1 [CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H/E:U/RL:O/RC:C] [PCI]

CVE-ID: CVE-2019-3829

CWE-ID: CWE-415 - Double Free

Description

The vulnerability allows a remote attacker to execute arbitrary code on the target system.

The vulnerability exists due to a double free error in the certificate verification API when processing X.509  crtificates. A remote attacker can supply a specially crafted X.509  certificate, trigger double free error and execute arbitrary code on the target system.

Successful exploitation of this vulnerability may result in complete compromise of vulnerable system.

Mitigation

Install updates from vendor's website.

Vulnerable software versions

GnuTLS: 3.5.8, 3.5.9, 3.5.10, 3.5.11, 3.5.12, 3.5.13, 3.5.14, 3.5.15, 3.5.16, 3.5.17, 3.5.18, 3.5.19, 3.6.0, 3.6.0.1, 3.6.1, 3.6.2, 3.6.3, 3.6.4, 3.6.5, 3.6.6

CPE External links

https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2019-3829
https://gitlab.com/gnutls/gnutls/issues/694
https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/L7TJIBRJWGWSH6XIO2MXIQ3W6ES4R6I4/
https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/WRSOL66LHP4SD3Y2ECJDOGT4K663ECDU/



Q & A

Can this vulnerability be exploited remotely?

Yes. This vulnerability can be exploited by a remote non-authenticated attacker via the Internet.

Is there known malware, which exploits this vulnerability?

No. We are not aware of malware exploiting this vulnerability.

2) Buffer overflow

Severity: Medium

CVSSv3: 5.2 [CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H/E:U/RL:O/RC:C] [PCI]

CVE-ID: CVE-2019-3836

CWE-ID: CWE-119 - Improper Restriction of Operations within the Bounds of a Memory Buffer

Description

The vulnerability allows a remote attacker to perform denial of service attack.

The vulnerability exists due to uninitialized pointer access when processing TLS1.3 asynchronous messages. A remote attacker can pass specially crafted asynchronous post-handshake message, trigger memory corruption and perform denial of service attack.

Mitigation

Install updates from vendor's website.

Vulnerable software versions

GnuTLS: 3.6.4, 3.6.5, 3.6.6

CPE External links

https://gitlab.com/gnutls/gnutls/issues/704

Q & A

Can this vulnerability be exploited remotely?

Yes. This vulnerability can be exploited by a remote non-authenticated attacker via the Internet.

Is there known malware, which exploits this vulnerability?

No. We are not aware of malware exploiting this vulnerability.