Spoofing attack in OpenSUSE osc



Published: 2019-08-12
Severity Low
Patch available YES
Number of vulnerabilities 1
CVE ID CVE-2019-3685
CWE ID CWE-451
Exploitation vector Network
Public exploit N/A
Vulnerable software
Subscribe
osc
Client/Desktop applications / Other client software

Vendor openSUSE

Security Advisory

This security advisory describes one low risk vulnerability.

1) Spoofing attack

Severity: Low

CVSSv3: 3.7 [CVSS:3.0/AV:N/AC:H/PR:N/UI:R/S:U/C:L/I:L/A:N/E:U/RL:O/RC:C]

CVE-ID: CVE-2019-3685

CWE-ID: CWE-451 - User Interface (UI) Misrepresentation of Critical Information (Clickjacking, spoofing)

Description

The vulnerability allows a remote attacker to perform spoofing attack.

The vulnerability exists due to incorrect processing of untrusted TLS certificates. A remote attacker can create a specially crafted TLS certificate and perform Man-in-the-Middle (MitM) attack.

Mitigation

Install updates from vendor's website.

Vulnerable software versions

osc: 0.127, 0.128, 0.129, 0.129.1, 0.130, 0.130.1, 0.131, 0.131.0, 0.131.1, 0.132.0, 0.132.1, 0.132.2, 0.132.3, 0.132.4, 0.132.5, 0.132.6, 0.133, 0.133.1, 0.134.0, 0.134.1, 0.135.0, 0.135.1, 0.136.0, 0.137.0, 0.138.0, 0.139.0, 0.139.1, 0.139.2, 0.140.0, 0.140.1, 0.141.0, 0.142.0, 0.142.1, 0.142.2, 0.143.0, 0.144.0, 0.144.1, 0.145.0, 0.146.0, 0.147.0, 0.148.0, 0.148.1, 0.149.0, 0.150.0, 0.151.0, 0.151.1, 0.151.2, 0.152.0, 0.153.0, 0.154.0, 0.155.0, 0.155.1, 0.156.0, 0.157.0, 0.157.1, 0.157.2, 0.158.0, 0.159.0, 0.160.0, 0.161.0, 0.161.1, 0.162.0, 0.162.1, 0.163.0, 0.164.0, 0.164.1, 0.164.2, 0.165.0, 0.165.1, 0.165.2, 0.165.3

CPE External links

https://lists.opensuse.org/opensuse-security-announce/2019-08/msg00007.html

Q & A

Can this vulnerability be exploited remotely?

Yes. This vulnerability can be exploited by a remote non-authenticated attacker via the Internet.

Is there known malware, which exploits this vulnerability?

No. We are not aware of malware exploiting this vulnerability.