Denial of service in GNU Aspell

Published: 2019-10-20 | Updated: 2019-10-20
Severity Low
Patch available YES
Number of vulnerabilities 1
CVE ID CVE-2019-17544
CWE ID CWE-125
Exploitation vector Network
Public exploit N/A
Vulnerable software Aspell Subscribe
Vendor GNU

Security Advisory

This security advisory describes one low risk vulnerability.

1) Out-of-bounds read

Severity: Low

CVSSv3: 4.7 [CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:N/A:L/E:U/RL:O/RC:C] [PCI]

CVE-ID: CVE-2019-17544

CWE-ID: CWE-125 - Out-of-bounds Read

Description

The vulnerability allows a remote attacker to perform a denial of service (DoS) attack.

The vulnerability exists due to a boundary condition when processing an isolated character within the acommon::unescape() function in common/getdata.cpp file in GNU Aspell. A remote attacker can create a specially crafted Excel file, trick the victim into opening it, trigger out-of-bounds read error and read contents of memory on the system or crash the application.

Mitigation

Install update from vendor's website.

Vulnerable software versions

Aspell: 0.60, 0.60.1, 0.60.2, 0.60.3, 0.60.4, 0.60.5, 0.60.6, 0.60.6.1, 0.60.7

CPE External links

https://bugs.chromium.org/p/oss-fuzz/issues/detail?id=16109
https://github.com/GNUAspell/aspell/commit/80fa26c74279fced8d778351cff19d1d8f44fe4e
https://github.com/GNUAspell/aspell/compare/rel-0.60.7...rel-0.60.8

Q & A

Can this vulnerability be exploited remotely?

Yes. This vulnerability can be exploited by a remote non-authenticated attacker via the Internet.

Is there known malware, which exploits this vulnerability?

No. We are not aware of malware exploiting this vulnerability.