Red Hat update for rh-git218-git



Published: 2020-01-02
Risk High
Patch available YES
Number of vulnerabilities 4
CVE-ID CVE-2019-1387
CVE-2019-1352
CVE-2019-1349
CVE-2019-1348
CWE-ID CWE-20
CWE-22
Exploitation vector Network
Public exploit N/A
Vulnerable software
Subscribe
Red Hat Software Collections
Universal components / Libraries / Software for developers

Vendor Red Hat Inc.

Security Bulletin

This security bulletin contains information about 4 vulnerabilities.

1) Input validation error

EUVDB-ID: #VU23488

Risk: High

CVSSv3.1:

CVE-ID: CVE-2019-1387

CWE-ID: CWE-20 - Improper Input Validation

Exploit availability: No

Description

The vulnerability allows a remote attacker to execute arbitrary code on the target system.

The vulnerability exists due to insufficient validation of user-supplied input within the Git for Visual Studio. A remote attacker can convince the user to clone a malicious repo and execute arbitrary code on the target system. 

Mitigation

Install updates from vendor's website.

Vulnerable software versions

Red Hat Software Collections: 1 for RHEL 7 - 1 for RHEL 7.7


CPE2.3 External links

http://access.redhat.com/errata/RHSA-2020:0002

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?

2) Input validation error

EUVDB-ID: #VU23492

Risk: High

CVSSv3.1:

CVE-ID: CVE-2019-1352

CWE-ID: CWE-20 - Improper Input Validation

Exploit availability: No

Description

The vulnerability allows a remote attacker to execute arbitrary code on the target system.

The vulnerability exists due to insufficient validation of user-supplied input within the Git for Visual Studio. A remote attacker can convince the user to clone a malicious repo and execute arbitrary code on the target system.

Mitigation

Install updates from vendor's website.

Vulnerable software versions

Red Hat Software Collections: 1 for RHEL 7 - 1 for RHEL 7.7


CPE2.3 External links

http://access.redhat.com/errata/RHSA-2020:0002

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?

3) Input validation error

EUVDB-ID: #VU23494

Risk: High

CVSSv3.1:

CVE-ID: CVE-2019-1349

CWE-ID: CWE-20 - Improper Input Validation

Exploit availability: No

Description

The vulnerability allows a remote attacker to execute arbitrary code on the target system.

The vulnerability exists due to insufficient validation of user-supplied input within the Git for Visual Studio. A remote attacker can convince the user to clone a malicious repo and execute arbitrary code on the target system.

Mitigation

Install updates from vendor's website.

Vulnerable software versions

Red Hat Software Collections: 1 for RHEL 7 - 1 for RHEL 7.7


CPE2.3 External links

http://access.redhat.com/errata/RHSA-2020:0002

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?

4) Path traversal

EUVDB-ID: #VU23554

Risk: Medium

CVSSv3.1:

CVE-ID: CVE-2019-1348

CWE-ID: CWE-22 - Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal')

Exploit availability: No

Description

The vulnerability allows a remote attacker to perform directory traversal attacks.

The vulnerability exists due to input validation error when the export-marks option of git fast-import is exposed also via the in-stream command feature. A remote attacker can send a specially crafted HTTP request and overwrite arbitrary paths on the system.

Mitigation

Install updates from vendor's website.

Vulnerable software versions

Red Hat Software Collections: 1 for RHEL 7 - 1 for RHEL 7.7


CPE2.3 External links

http://access.redhat.com/errata/RHSA-2020:0002

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?



###SIDEBAR###