Multiple vulnerabilities in Some Huawei Products



Published: 2020-02-05 | Updated: 2020-06-03
Risk Medium
Patch available YES
Number of vulnerabilities 8
CVE-ID CVE-2020-1858
CVE-2020-1829
CVE-2020-1827
CVE-2020-1873
CVE-2020-1881
CVE-2020-1875
CVE-2020-1874
CVE-2020-1883
CWE-ID CWE-20
CWE-415
CWE-125
CWE-399
CWE-824
CWE-401
Exploitation vector Network
Public exploit N/A
Vulnerable software
Subscribe
Huawei NIP6800
Server applications / IDS/IPS systems, Firewalls and proxy servers

Huawei Secospace USG6600
Server applications / Server solutions for antivurus protection

USG9500
Hardware solutions / Routers & switches, VoIP, GSM, etc

Vendor Huawei

Security Bulletin

This security bulletin contains information about 8 vulnerabilities.

Updated 12.02.2020
Added vulnerability #2, changed bulletin severity to Medium
Updated 13.02.2020
Added vulnerability #3
Updated 19.02.2020
Added vulnerabilities #4-7
Updated 03.06.2020
Added vulnerability #8

1) Input validation error

EUVDB-ID: #VU24946

Risk: Low

CVSSv3.1: 3.2 [CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:L/E:U/RL:O/RC:C]

CVE-ID: CVE-2020-1858

CWE-ID: CWE-20 - Improper Input Validation

Exploit availability: No

Description

The vulnerability allows a remote attacker to perform a denial of service (DoS) attack.

The vulnerability exists due to insufficient validation of user-supplied input. A remote attacker can cause the new connections can't be established, result in a denial of service condition.

Mitigation

Install updates from vendor's website.

Vulnerable software versions

Huawei NIP6800: V500R001C30 - V500R005C00SPC100

Huawei Secospace USG6600: V500R001C30SPC600 - V500R005C00SPC100

USG9500: V500R001C30SPC600 - V500R005C00SPC100


CPE2.3 External links

http://www.huawei.com/en/psirt/security-advisories/huawei-sa-20200205-01-dos-en

Q & A

Can this vulnerability be exploited remotely?

Yes. This vulnerability can be exploited by a remote non-authenticated attacker via the Internet.

How the attacker can exploit this vulnerability?

The attacker would have to send a specially crafted request to the affected application in order to exploit this vulnerability.

Is there known malware, which exploits this vulnerability?

No. We are not aware of malware exploiting this vulnerability.

2) Double Free

EUVDB-ID: #VU25272

Risk: Medium

CVSSv3.1: 5.2 [CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H/E:U/RL:O/RC:C]

CVE-ID: CVE-2020-1829

CWE-ID: CWE-415 - Double Free

Exploit availability: No

Description

The vulnerability allows a remote attacker to compromise normal service.

The vulnerability exists due to a boundary error when the IPSec module handles a message improperly. A remote attacker can send specific message to affected product, trigger double free error and compromise normal service.

Mitigation

Install updates from vendor's website.

Vulnerable software versions

Huawei NIP6800: V500R001C30 - V500R001C60SPC500

Huawei Secospace USG6600: V500R001C30SPC200 - V500R001C60SPC500

USG9500: V500R001C30SPC200 - V500R001C60SPC500


CPE2.3 External links

http://www.huawei.com/en/psirt/security-advisories/huawei-sa-20200212-03-ipsec-en

Q & A

Can this vulnerability be exploited remotely?

Yes. This vulnerability can be exploited by a remote non-authenticated attacker via the Internet.

How the attacker can exploit this vulnerability?

The attacker would have to send a specially crafted request to the affected application in order to exploit this vulnerability.

Is there known malware, which exploits this vulnerability?

No. We are not aware of malware exploiting this vulnerability.

3) Input validation error

EUVDB-ID: #VU25288

Risk: Medium

CVSSv3.1: 5.2 [CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H/E:U/RL:O/RC:C]

CVE-ID: CVE-2020-1827

CWE-ID: CWE-20 - Improper Input Validation

Exploit availability: No

Description

The vulnerability allows a remote attacker to perform a denial of service (DoS) attack.

The vulnerability exists due to the IPSec Module handles a specific message incorrectly. A remote attacker can send a specially crafted message and cause a denial of service condition in IPSec module.

Mitigation

Install updates from vendor's website.

Vulnerable software versions

Huawei NIP6800: V500R001C30 - V500R005C00SPC100

Huawei Secospace USG6600: V500R001C30SPC200 - V500R001C60SPC500

USG9500: V500R001C30SPC200 - V500R005C00SPC100


CPE2.3 External links

http://www.huawei.com/en/psirt/security-advisories/huawei-sa-20200212-02-ipsec-en

Q & A

Can this vulnerability be exploited remotely?

Yes. This vulnerability can be exploited by a remote non-authenticated attacker via the Internet.

How the attacker can exploit this vulnerability?

The attacker would have to send a specially crafted request to the affected application in order to exploit this vulnerability.

Is there known malware, which exploits this vulnerability?

No. We are not aware of malware exploiting this vulnerability.

4) Out-of-bounds read

EUVDB-ID: #VU25435

Risk: Medium

CVSSv3.1: 5.2 [CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H/E:U/RL:O/RC:C]

CVE-ID: CVE-2020-1873

CWE-ID: CWE-125 - Out-of-bounds Read

Exploit availability: No

Description

The vulnerability allows a remote attacker to perform a denial of service (DoS) attack.

The vulnerability exists due to a boundary condition when processing messages. A remote attacker can send a specially crafted message with specific parameter, trigger out-of-bounds read error and cause the device reboot.

Mitigation

Install updates from vendor's website.

Vulnerable software versions

Huawei NIP6800: V500R001C30 - V500R005C00SPC100

Huawei Secospace USG6600: V500R001C30SPC200 - V500R001C60SPC500

USG9500: V500R001C30SPC200 - V500R005C00SPC100


CPE2.3 External links

http://www.huawei.com/en/psirt/security-advisories/huawei-sa-20200219-01-outofboundread-en

Q & A

Can this vulnerability be exploited remotely?

Yes. This vulnerability can be exploited by a remote non-authenticated attacker via the Internet.

How the attacker can exploit this vulnerability?

The attacker would have to send a specially crafted request to the affected application in order to exploit this vulnerability.

Is there known malware, which exploits this vulnerability?

No. We are not aware of malware exploiting this vulnerability.

5) Resource management error

EUVDB-ID: #VU25434

Risk: Medium

CVSSv3.1: 4.6 [CVSS:3.1/AV:A/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H/E:U/RL:O/RC:C]

CVE-ID: CVE-2020-1881

CWE-ID: CWE-399 - Resource Management Errors

Exploit availability: No

Description

The vulnerability allows a remote attacker to perform a denial of service (DoS) attack.

The vulnerability exists due to improper resource management of the function. A remote attacker on the local network can perform specific operations to trigger the function of the affected device and cause service abnormal on affected devices.

Mitigation

Install updates from vendor's website.

Vulnerable software versions

Huawei NIP6800: V500R001C30

Huawei Secospace USG6600: V500R001C30SPC200 - V500R001C30SPC600

USG9500: V500R001C30SPC200 - V500R001C30SPC600


CPE2.3 External links

http://www.huawei.com/en/psirt/security-advisories/huawei-sa-20200219-02-resource-en

Q & A

Can this vulnerability be exploited remotely?

Yes. This vulnerability can be exploited by a remote non-authenticated attacker via the local network (LAN).

How the attacker can exploit this vulnerability?

The attacker would have to send a specially crafted request to the affected application in order to exploit this vulnerability.

Is there known malware, which exploits this vulnerability?

No. We are not aware of malware exploiting this vulnerability.

6) Access of Uninitialized Pointer

EUVDB-ID: #VU25439

Risk: Low

CVSSv3.1: 4.5 [CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H/E:U/RL:O/RC:C]

CVE-ID: CVE-2020-1875

CWE-ID: CWE-824 - Access of Uninitialized Pointer

Exploit availability: No

Description

The vulnerability allows a local attacker to perform a denial of service (DoS) attack.

The vulnerability exists due to the affected software system access an invalid pointer when an abnormal condition occurs in certain operation. A local attacker can cause certain process reboot.

Mitigation

Install updates from vendor's website.

Vulnerable software versions

Huawei NIP6800: V500R001C30 - V500R001C60SPC500

Huawei Secospace USG6600: V500R001C30SPC200 - V500R001C60SPC500

USG9500: V500R001C30SPC200 - V500R001C60SPC500


CPE2.3 External links

http://www.huawei.com/en/psirt/security-advisories/huawei-sa-20200219-01-wildpointer-en

Q & A

Can this vulnerability be exploited remotely?

No. This vulnerability can be exploited locally. The attacker should have authentication credentials and successfully authenticate on the system.

How the attacker can exploit this vulnerability?

The attacker would have to send a specially crafted request to the affected application in order to exploit this vulnerability.

The attacker would have to login to the system and perform certain actions in order to exploit this vulnerability.

Is there known malware, which exploits this vulnerability?

No. We are not aware of malware exploiting this vulnerability.

7) Access of Uninitialized Pointer

EUVDB-ID: #VU25438

Risk: Low

CVSSv3.1: 3.6 [CVSS:3.1/AV:L/AC:H/PR:H/UI:N/S:U/C:N/I:N/A:H/E:U/RL:O/RC:C]

CVE-ID: CVE-2020-1874

CWE-ID: CWE-824 - Access of Uninitialized Pointer

Exploit availability: No

Description

The vulnerability allows a local user to perform a denial of service (DoS) attack.

The vulnerability exists due to the affected software system access an invalid pointer when operator logs in to the device and performs some operations. A local user can cause certain process reboot.

Mitigation

Install updates from vendor's website.

Vulnerable software versions

Huawei NIP6800: V500R001C30 - V500R005C00SPC100

Huawei Secospace USG6600: V500R001C30SPC200 - V500R001C60SPC500

USG9500: V500R001C30SPC200 - V500R005C00SPC100


CPE2.3 External links

http://www.huawei.com/en/psirt/security-advisories/huawei-sa-20200219-02-invalidpointer-en

Q & A

Can this vulnerability be exploited remotely?

No. This vulnerability can be exploited locally. The attacker should have authentication credentials and successfully authenticate on the system.

How the attacker can exploit this vulnerability?

The attacker would have to send a specially crafted request to the affected application in order to exploit this vulnerability.

The attacker would have to login to the system and perform certain actions in order to exploit this vulnerability.

Is there known malware, which exploits this vulnerability?

No. We are not aware of malware exploiting this vulnerability.

8) Memory leak

EUVDB-ID: #VU28546

Risk: Low

CVSSv3.1: 4.3 [CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:N/A:H/E:U/RL:O/RC:C]

CVE-ID: CVE-2020-1883

CWE-ID: CWE-401 - Improper Release of Memory Before Removing Last Reference ('Memory Leak')

Exploit availability: No

Description

The vulnerability allows a remote user to perform denial fo service (DoS) attack on the target system.

The vulnerability exists due memory leak. A remote administrator can force the application to leak memory and perform denial of service attack.

Mitigation

Install updates from vendor's website.

Vulnerable software versions

Huawei Secospace USG6600: V500R001C30SPC200 - V500R001C60SPC500

USG9500: V500R001C30SPC600 - V500R001C60SPC500

Huawei NIP6800: V500R001C60SPC500


CPE2.3 External links

http://www.huawei.com/en/psirt/security-advisories/huawei-sa-20200603-01-memory-en

Q & A

Can this vulnerability be exploited remotely?

Yes. This vulnerability can be exploited by a remote authenticated privileged user via the Internet.

How the attacker can exploit this vulnerability?

The attacker would have to send a specially crafted request to the affected application in order to exploit this vulnerability.

Is there known malware, which exploits this vulnerability?

No. We are not aware of malware exploiting this vulnerability.



###SIDEBAR###