Show vulnerabilities with patch / with exploit

SQL injection in WordPress Infinite Scroll – Ajax Load More plugin



Published: 2020-05-18
Severity High
Patch available YES
Number of vulnerabilities 1
CVE ID N/A
CWE ID CWE-89
Exploitation vector Network
Public exploit Public exploit code for vulnerability #1 is available.
Vulnerable software
Subscribe
WordPress Infinite Scroll – Ajax Load More
Web applications / Modules and components for CMS

Vendor Darren Cooney

Security Advisory

This security advisory describes one high risk vulnerability.

1) SQL injection

Severity: High

CVSSv3: 7.9 [CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H/E:P/RL:O/RC:C] [PCI]

CVE-ID: N/A

CWE-ID: CWE-89 - Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection')

Exploit availability: Yes [Search exploit]

Description

The vulnerability allows a remote attacker to execute arbitrary SQL queries in database.

The vulnerability exists due to insufficient sanitization of user-supplied data in POST "/wp-admin/admin-ajax.php" page with param repeater=' or sleep(5)#&type=test. A remote authenticated attacker can send a specially crafted request to the affected application and execute arbitrary SQL commands within the application database.

Successful exploitation of this vulnerability may allow a remote attacker to read, delete, modify data in database and gain complete control over the affected application.

Mitigation

Install updates from vendor's website.

Vulnerable software versions

WordPress Infinite Scroll – Ajax Load More: 2.0.3, 2.0.5, 2.1.1, 2.1.3, 2.2.1, 2.2.2, 2.2.3, 2.2.6, 2.2.7, 2.2.8, 2.3.1, 2.4.0, 2.4.1, 2.5.1, 2.6.0, 2.6.1, 2.6.2, 2.6.3, 2.6.3.1, 2.6.3.2, 2.7.0, 2.7.1, 2.7.2, 2.7.3, 2.8.0, 2.8.1.2, 2.8.2, 2.8.3, 2.8.4, 2.8.5, 2.8.6, 2.9.0, 2.10.0.1, 2.10.1, 2.11.0, 2.11.1, 2.11.2, 2.12.0, 2.13.0, 2.13.0.1, 2.13.1, 2.14.0, 2.14.1, 3.0, 3.0.1, 3.1.0, 3.1.1, 3.1.2, 3.2, 3.2.1, 3.3.0, 3.3.0.1, 3.3.1, 3.4.0, 3.4.1, 3.5, 3.5.1, 3.6, 3.6.1, 3.7.1, 4.0, 4.1.0, 4.2.0.1, 5.0.1, 5.0.2, 5.1.0, 5.1.0.1, 5.1.1, 5.1.2, 5.1.3, 5.1.4, 5.1.5, 5.1.6, 5.1.6.1, 5.1.7, 5.1.7.1, 5.1.7.2, 5.1.8, 5.2.0, 5.3.0, 5.3.1

CPE External links

https://wpvulndb.com/vulnerabilities/10230/
https://www.exploit-db.com/exploits/48475

Q & A

Can this vulnerability be exploited remotely?

Yes. This vulnerability can be exploited by a remote authenticated user via the Internet.

Is there known malware, which exploits this vulnerability?

No. We are not aware of malware exploiting this vulnerability. However, proof of concept for this vulnerability is available.



ImmuniWeb® AI Platform for Application Security Testing