Multiple vulnerabilities in NETGEAR Routers



Published: 2021-01-19

Security Advisory

1) Improper Authentication

Risk: Medium

CVSSv3: 7.7 [CVSS:3.0/AV:A/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H/E:U/RL:O/RC:C] [PCI]

CVE-ID: CVE-2020-27872

CWE-ID: CWE-287 - Improper Authentication

Exploit availability: No

Description

The vulnerability allows a remote attacker to bypass authentication process.

The vulnerability exists due to improper state tracking in the password recovery process within the "mini_httpd" service. A remote attacker on the local network can bypass authentication process and gain unauthorized access to the application.

Mitigation

Install updates from vendor's website.

Vulnerable software versions

AC2100: before 1.2.0.76

AC2400: before 1.2.0.76

AC2600: before 1.2.0.76

R6700v2: before 1.2.0.76

R6800: before 1.2.0.76

R6900v2: before 1.2.0.76

R7200: before 1.2.0.76

R7350: before 1.2.0.76

R7400: before 1.2.0.76

R7450: before 1.2.0.76

R6220: before 1.1.0.104

R6230: before 1.1.0.104

R6260: before 1.1.0.78

R6330: before 1.1.0.78

R6350: before 1.1.0.78

R6850: before 1.1.0.78

R6120: before 1.0.0.76

R6020: before 1.0.0.48

R6080: before 1.0.0.48

CPE External links

https://www.zerodayinitiative.com/advisories/ZDI-21-071/
https://kb.netgear.com/000062641/Security-Advisory-for-Password-Recovery-Vulnerabilities-on-Some-Routers

Q & A

Can this vulnerability be exploited remotely?

Yes. This vulnerability can be exploited by a remote non-authenticated attacker via the local network (LAN).

Is there known malware, which exploits this vulnerability?

No. We are not aware of malware exploiting this vulnerability.

2) Improper Authentication

Risk: Low

CVSSv3: 5.9 [CVSS:3.0/AV:A/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H/E:U/RL:O/RC:C] [PCI]

CVE-ID: N/A

CWE-ID: CWE-287 - Improper Authentication

Exploit availability: No

Description

The vulnerability allows a remote user to bypass authentication process.

The vulnerability exists due to an error in when processing authentication requests. A remote administrator on the local network can bypass authentication process and gain unauthorized access to the application.

Mitigation

Install updates from vendor's website.

Vulnerable software versions

AC2100: before 1.2.0.76

AC2400: before 1.2.0.76

AC2600: before 1.2.0.76

R6700v2: before 1.2.0.76

R6800: before 1.2.0.76

R6900v2: before 1.2.0.76

R7200: before 1.2.0.76

R7350: before 1.2.0.76

R7400: before 1.2.0.76

R7450: before 1.2.0.76

R6220: before 1.1.0.104

R6230: before 1.1.0.104

R6260: before 1.1.0.78

R6330: before 1.1.0.78

R6350: before 1.1.0.78

R6850: before 1.1.0.78

R6120: before 1.0.0.76

R6020: before 1.0.0.48

R6080: before 1.0.0.48

CPE External links

https://kb.netgear.com/000062641/Security-Advisory-for-Password-Recovery-Vulnerabilities-on-Some-Rou...

Q & A

Can this vulnerability be exploited remotely?

Yes. This vulnerability can be exploited by a remote authenticated privileged user via the local network (LAN).

Is there known malware, which exploits this vulnerability?

No. We are not aware of malware exploiting this vulnerability.

3) Improper Authentication

Risk: Low

CVSSv3: 5.9 [CVSS:3.0/AV:A/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H/E:U/RL:O/RC:C] [PCI]

CVE-ID: N/A

CWE-ID: CWE-287 - Improper Authentication

Exploit availability: No

Description

The vulnerability allows a remote user to bypass authentication process.

The vulnerability exists due to an error in when processing authentication requests. A remote administrator on the local network can bypass authentication process and gain unauthorized access to the application.

Mitigation

Install updates from vendor's website.

Vulnerable software versions

AC2100: before 1.2.0.76

AC2400: before 1.2.0.76

AC2600: before 1.2.0.76

R6700v2: before 1.2.0.76

R6800: before 1.2.0.76

R6900v2: before 1.2.0.76

R7200: before 1.2.0.76

R7350: before 1.2.0.76

R7400: before 1.2.0.76

R7450: before 1.2.0.76

R6220: before 1.1.0.104

R6230: before 1.1.0.104

R6260: before 1.1.0.78

R6330: before 1.1.0.78

R6350: before 1.1.0.78

R6850: before 1.1.0.78

R6120: before 1.0.0.76

R6020: before 1.0.0.48

R6080: before 1.0.0.48

CPE External links

https://kb.netgear.com/000062641/Security-Advisory-for-Password-Recovery-Vulnerabilities-on-Some-Rou...

Q & A

Can this vulnerability be exploited remotely?

Yes. This vulnerability can be exploited by a remote authenticated privileged user via the local network (LAN).

Is there known malware, which exploits this vulnerability?

No. We are not aware of malware exploiting this vulnerability.

4) Improper access control

Risk: Low

CVSSv3: 5.7 [CVSS:3.0/AV:A/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N/E:U/RL:O/RC:C] [PCI]

CVE-ID: CVE-2020-27873

CWE-ID: CWE-284 - Improper Access Control

Exploit availability: No

Description

The vulnerability allows a remote attacker to gain access to potentially sensitive information.

The vulnerability exists due to improper access restrictions within the SOAP API endpoint. A remote attacker on the local network can gain unauthorized access to sensitive information on the system.

Mitigation

Install updates from vendor's website.

Vulnerable software versions

AC2100: before 1.2.0.76

AC2400: before 1.2.0.76

AC2600: before 1.2.0.76

R6700v2: before 1.2.0.76

R6800: before 1.2.0.76

R6900v2: before 1.2.0.76

R7200: before 1.2.0.76

R7350: before 1.2.0.76

R7400: before 1.2.0.76

R7450: before 1.2.0.76

R6220: before 1.1.0.104

R6230: before 1.1.0.104

R6260: before 1.1.0.78

R6330: before 1.1.0.78

R6350: before 1.1.0.78

R6850: before 1.1.0.78

R6120: before 1.0.0.76

R6020: before 1.0.0.48

R6080: before 1.0.0.48

CPE External links

https://kb.netgear.com/000062641/Security-Advisory-for-Password-Recovery-Vulnerabilities-on-Some-Rou...
https://www.zerodayinitiative.com/advisories/ZDI-21-072/

Q & A

Can this vulnerability be exploited remotely?

Yes. This vulnerability can be exploited by a remote non-authenticated attacker via the local network (LAN).

Is there known malware, which exploits this vulnerability?

No. We are not aware of malware exploiting this vulnerability.



###SIDEBAR###