Information disclosure in containerd



Published: 2021-03-05
Risk Medium
Patch available YES
Number of vulnerabilities 1
CVE ID CVE-2021-21334
CWE ID CWE-399
Exploitation vector Network
Public exploit N/A
Vulnerable software
Subscribe
containerd
Other software / Other software solutions

Vendor containerd

Security Advisory

This security advisory describes one medium risk vulnerability.

1) Resource management error

Risk: Medium

CVSSv3.1: 5.7 [CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N/E:U/RL:O/RC:C] [PCI]

CVE-ID: CVE-2021-21334

CWE-ID: CWE-399 - Resource Management Errors

Exploit availability: No

Description

The vulnerability allows an attacker to gain access to potentially sensitive information.

The vulnerability exists due to incorrect management of internal resources. Containers launched through containerd's CRI implementation (through Kubernetes, crictl, or any other pod/container client that uses the containerd CRI service) that share the same image may receive incorrect environment variables, including values that are defined for other containers. If the affected containers have different security contexts, this may allow sensitive information to be unintentionally shared.

Mitigation

Install updates from vendor's website.

Vulnerable software versions

containerd: 1.3.0, 1.3.1, 1.3.2, 1.3.3, 1.3.4, 1.3.5, 1.3.6, 1.3.7, 1.3.8, 1.3.9, 1.4.0, 1.4.1, 1.4.2, 1.4.3

CPE External links

https://github.com/containerd/containerd/security/advisories/GHSA-6g2q-w5j3-fwh4
https://github.com/containerd/containerd/releases/tag/v1.3.10
https://github.com/containerd/containerd/releases/tag/v1.4.4

Q & A

Can this vulnerability be exploited remotely?

Yes. This vulnerability can be exploited by a remote authenticated user via the Internet.

Is there known malware, which exploits this vulnerability?

No. We are not aware of malware exploiting this vulnerability.



###SIDEBAR###