Denial of service in glibc implementation in F5 BIG-IP and F5OS



Published: 2021-03-12

Security Bulletin

This security bulletin contains one low risk vulnerability.

1) Out-of-bounds read

EUVDB-ID: #VU50329

Risk: Low

CVSSv3.1:

CVE-ID: CVE-2019-25013

CWE-ID: CWE-125 - Out-of-bounds Read

Exploit availability: No

Description

The vulnerability allows a remote attacker to perform a denial of service (DoS) attack.

The vulnerability exists due to a boundary condition in GNU C Library within the iconv feature when processing multi-byte input sequences in the EUC-KR encoding. A remote attacker can pass specially crafted input to the application, trigger out-of-bounds read error and perform a denial of service (DoS) attack.

Mitigation

Cybersecurity Help is currently unaware of any official solution to address this vulnerability.

Vulnerable software versions

BIG-IP SSLO: 11.6.1 - 16.0.1.1

BIG-IP PEM: 11.6.1 - 16.0.1.1

BIG-IP Link Controller: 11.6.1 - 16.0.1.1

BIG-IP GTM: 11.6.1 - 16.0.1.1

BIG-IP FPS: 11.6.1 - 16.0.1.1

BIG-IP DNS: 11.6.1 - 16.0.1.1

BIG-IP DDHD: 11.6.1 - 16.0.1.1

BIG-IP APM: 11.6.1 - 16.0.1.1

BIG-IP Analytics: 11.6.1 - 16.0.1.1

BIG-IP AFM: 11.6.1 - 16.0.1.1

BIG-IP Advanced WAF: 11.6.1 - 16.0.1.1

BIG-IP AAM: 11.6.1 - 16.0.1.1

BIG-IP LTM: 11.6.1 - 16.0.1.1

BIG-IP: 11.6.1 - 16.0.1.1

BIG-IP ASM: 11.6.1 - 16.0.1.1

BIG-IQ Centralized Management: 6.0.0 - 8.0.0

F5OS: 1.0.0


CPE2.3 External links

http://support.f5.com/csp/article/K68251873

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?



###SIDEBAR###