Multiple vulnerabilities in Grafana



Published: 2021-03-19
Risk Medium
Patch available YES
Number of vulnerabilities 4
CVE-ID CVE-2021-27962
CVE-2021-28146
CVE-2021-28147
CVE-2021-28148
CWE-ID CWE-269
CWE-284
CWE-799
Exploitation vector Network
Public exploit N/A
Vulnerable software
Subscribe
Grafana
Web applications / Other software

Vendor Grafana Labs

Security Bulletin

This security bulletin contains information about 4 vulnerabilities.

1) Improper Privilege Management

EUVDB-ID: #VU51579

Risk: Low

CVSSv3.1:

CVE-ID: CVE-2021-27962

CWE-ID: CWE-269 - Improper Privilege Management

Exploit availability: No

Description

The vulnerability allows a remote attacker to escalate privileges within the application.

The vulnerability exists due to improper privilege management. A remote user with Editor privileges can bypass data source permissions on the organization's default data source.

Mitigation

Install updates from vendor's website.

Vulnerable software versions

Grafana: 7.4.0 - 7.4.3, 7.3.0 - 7.3.7, 7.2.0 - 7.2.3


CPE2.3 External links

http://grafana.com/blog/2021/03/18/grafana-6.7.6-7.3.10-and-7.4.5-released-with-important-security-fixes-for-grafana-enterprise/

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?

2) Improper access control

EUVDB-ID: #VU51580

Risk: Medium

CVSSv3.1:

CVE-ID: CVE-2021-28146

CWE-ID: CWE-284 - Improper Access Control

Exploit availability: No

Description

The vulnerability allows a remote user to gain unauthorized access to otherwise restricted functionality.

The vulnerability exists due to improper access restrictions. A remote user can bypass implemented security restrictions and add external groups to existing teams.

Mitigation

Install updates from vendor's website.

Vulnerable software versions

Grafana: 7.4.0 - 7.4.3


CPE2.3 External links

http://grafana.com/blog/2021/03/18/grafana-6.7.6-7.3.10-and-7.4.5-released-with-important-security-fixes-for-grafana-enterprise/

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?

3) Improper access control

EUVDB-ID: #VU51581

Risk: Medium

CVSSv3.1:

CVE-ID: CVE-2021-28147

CWE-ID: CWE-284 - Improper Access Control

Exploit availability: No

Description

The vulnerability allows a remote user to gain unauthorized access to otherwise restricted functionality.

The vulnerability exists due to improper access restrictions, when editorsCanAdmin  feature is enabled. A remote user can bypass implemented security restrictions and add external group members to existing teams.

Mitigation

Install updates from vendor's website.

Vulnerable software versions

Grafana: 7.4.0 - 7.4.3, 7.3.0 - 7.3.7, 7.2.0 - 7.2.3, 7.1.0 - 7.1.5, 7.0.0 - 7.0.6, 6.7.0 - 6.7.5, 6.6.0 - 6.6.2, 6.5 - 6.5.3, 6.4.0 - 6.4.5, 6.3.0 - 6.3.7, 6.2.0 - 6.2.5, 6.1.0 - 6.1.6


CPE2.3 External links

http://grafana.com/blog/2021/03/18/grafana-6.7.6-7.3.10-and-7.4.5-released-with-important-security-fixes-for-grafana-enterprise/

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?

4) Improper control of interaction frequency

EUVDB-ID: #VU51582

Risk: Medium

CVSSv3.1:

CVE-ID: CVE-2021-28148

CWE-ID: CWE-799 - Improper Control of Interaction Frequency

Exploit availability: No

Description

The vulnerability allows a remote attacker to perform a denial of service (DoS) attack.

The vulnerability exists due to absent control of interaction frequency within the HTTP API endpoint for insights usage. A remote non-authenticated attacker send multiple HTTP requests and perform a denial of service (DoS) attack.

Mitigation

Install updates from vendor's website.

Vulnerable software versions

Grafana: 7.4.0 - 7.4.3, 7.3.0 - 7.3.7, 7.2.0 - 7.2.3, 7.1.0 - 7.1.5, 7.0.0 - 7.0.6, 6.7.0 - 6.7.5, 6.6.0 - 6.6.2


CPE2.3 External links

http://grafana.com/blog/2021/03/18/grafana-6.7.6-7.3.10-and-7.4.5-released-with-important-security-fixes-for-grafana-enterprise/

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?



###SIDEBAR###