Red Hat Enterprise Linux 7.4 update for glibc



Published: 2021-07-22
Risk Medium
Patch available YES
Number of vulnerabilities 1
CVE ID CVE-2020-29573
CWE ID CWE-787
Exploitation vector Network
Public exploit N/A
Vulnerable software
Subscribe
Red Hat Enterprise Linux Server - Update Services for SAP Solutions
Operating systems & Components / Operating system package or component

Red Hat Enterprise Linux Server (for IBM Power LE) - Update Services for SAP Solutions
Operating systems & Components / Operating system package or component

glibc (Red Hat package)
Operating systems & Components / Operating system package or component

Red Hat Enterprise Linux Server - TUS
Operating systems & Components / Operating system

Red Hat Enterprise Linux Server - AUS
Operating systems & Components / Operating system

Vendor Red Hat Inc.

Security Advisory

This security advisory describes one medium risk vulnerability.

1) Out-of-bounds write

Risk: Medium

CVSSv3.1: 5.2 [CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H/E:U/RL:O/RC:C] [PCI]

CVE-ID: CVE-2020-29573

CWE-ID: CWE-787 - Out-of-bounds Write

Exploit availability: No

Description

The vulnerability allows a remote attacker to perform a denial of service (DoS) attack.

The vulnerability exists due to a boundary within the sysdeps/i386/ldbl2mpn.c in the GNU C Library on x86  systems. A remote attacker can pass specially crafted data to the application that uses the vulnerable version of glibc and crash it.

Mitigation

Install updates from vendor's website.

Vulnerable software versions

Red Hat Enterprise Linux Server - Update Services for SAP Solutions: 7.4

Red Hat Enterprise Linux Server (for IBM Power LE) - Update Services for SAP Solutions: 7.4

Red Hat Enterprise Linux Server - TUS: 7.4

Red Hat Enterprise Linux Server - AUS: 7.4

glibc (Red Hat package): before 2.17-196.el7_4.4

CPE External links

https://access.redhat.com/errata/RHSA-2021:2813

Q & A

Can this vulnerability be exploited remotely?

Yes. This vulnerability can be exploited by a remote non-authenticated attacker via the Internet.

Is there known malware, which exploits this vulnerability?

No. We are not aware of malware exploiting this vulnerability.



###SIDEBAR###